您现在的位置: 365建站网 > 365学习 > 在ArcGIS9.3中修改ESRI自带脚本库

在ArcGIS9.3中修改ESRI自带脚本库

文章来源:365jz.com     点击数:180    更新时间:2009-09-17 10:24   参与评论

 ArcGIS Server,为Web ADF提供了一组客户端脚本,在系统运行时,这些脚本被加载到浏览器中。在以往的版本中,用户可以修改这些脚本,以实现个性化的功能。例如:修改postBackError函数,用于弹出个性化的异常提示;但是,在ArcGIS 9.3中,这些修改已经不起作用了,因为在9.3版本的Web ADF中,最终加载到浏览器的脚本,不是从原来的路径复制过去,而是直接包含在组件中,在通常情况下,用户无法修改(除非反编译)。

不知为何,ESRI在版本更新中,为了防止用户篡改脚本作了以上更改。然而,道高一尺,魔高一丈。在灵活的JavaScript面前,很多问题都可以轻易的解决。还是以修改postBackError函数为例,我们只要在地图页面初始化的函数中,加入以下代码:

如对本文有疑问,请提交到交流论坛,广大热心网友会为你解答!! 点击进入论坛


发表评论 (180人查看0条评论)
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
用户名: 验证码: 点击我更换图片
最新评论
------分隔线----------------------------